nixos/machines/optimus.nix
Brendan Golden 34b2ef6a84
feat: got teh wing working
its not 100% ready for prod yet as there is no way to transfer from ptero yet
2024-12-10 00:44:38 +00:00

51 lines
834 B
Nix

/*
Name: https://en.wikipedia.org/wiki/Optimus_Prime
Why: Created to sell toys so this vm is for games
Type: VM
Hardware: -
From: 2023
Role: Game host
Notes:
*/
{
pkgs,
lib,
nodes,
arion,
...
}: let
# name of the server, sets teh hostname and record for it
name = "optimus-test";
ip_pub = "193.1.99.85";
hostname = "${name}.skynet.ie";
host = {
ip = ip_pub;
name = name;
hostname = hostname;
};
in {
imports = [
../applications/pelican/pelican.nix
];
deployment = {
targetHost = hostname;
targetPort = 22;
targetUser = null;
tags = ["active"];
};
services.skynet = {
host = host;
#backup.enable = true;
pelican = {
panel.enable = true;
wing = {
enable = true;
node_name = "node01";
};
};
};
}