59 lines
1.1 KiB
Nix
59 lines
1.1 KiB
Nix
{
|
|
config,
|
|
lib,
|
|
pkgs,
|
|
...
|
|
}:
|
|
with lib; let
|
|
# root service
|
|
cfg = config.services.skynet;
|
|
in {
|
|
imports = [
|
|
./acme.nix
|
|
./dns.nix
|
|
./nginx.nix
|
|
];
|
|
|
|
options.services.skynet = {
|
|
# since we use this basically everywhere provide a standard way to set it
|
|
host = {
|
|
ip = mkOption {
|
|
type = types.str;
|
|
};
|
|
name = mkOption {
|
|
type = types.str;
|
|
};
|
|
hostname = mkOption {
|
|
type = types.str;
|
|
default = "${cfg.host.name}.skynet.ie";
|
|
};
|
|
};
|
|
};
|
|
|
|
config = {
|
|
services.skynet.dns.records = [
|
|
{
|
|
record = cfg.host.name;
|
|
r_type = "A";
|
|
value = cfg.host.ip;
|
|
server = true;
|
|
}
|
|
{
|
|
record = cfg.host.ip;
|
|
r_type = "PTR";
|
|
value = cfg.host.hostname;
|
|
}
|
|
];
|
|
|
|
services.nginx = {
|
|
virtualHosts = {
|
|
# for every server unless explisitly defined redirect the ip to skynet.ie
|
|
"${cfg.host.ip}" = {
|
|
forceSSL = true;
|
|
useACMEHost = "skynet";
|
|
locations."/".return = "307 https://skynet.ie";
|
|
};
|
|
};
|
|
};
|
|
};
|
|
}
|