misc_pterodactyl-panel/shell.nix
2023-10-10 13:13:00 -06:00

19 lines
336 B
Nix

{
composer ? null,
php81WithExtensions ? null,
pkgs ? import <nixpkgs> {},
}:
with pkgs;
mkShell rec {
buildInputs = [
alejandra
composer
nodejs_18
nodePackages.yarn
php81WithExtensions
];
shellHook = ''
PATH="$PATH:${pkgs.docker-compose}/libexec/docker/cli-plugins"
'';
}